Forum Settings
       
1 2 3 Next »
Reply To Thread

Tooltips FeedbackFollow

#102 Jun 26 2012 at 5:18 PM Rating: Decent
7 posts
*shamless bump*
#104 Jul 02 2012 at 1:53 PM Rating: Decent
7 posts
Anyone with knowledge as to why this is going on even check this thread anymore?
#105 Jul 02 2012 at 7:53 PM Rating: Excellent
Avatar
******
29,911 posts
PM Jerek. That will be your best bet for resolution.
____________________________
Arch Duke Kaolian Drachensborn, lvl 95 Ranger, Unrest Server
Tech support forum | FAQ (Support) | Mobile Zam: http://m.zam.com (Premium only)
Forum Rules
#106 Jul 16 2012 at 1:18 AM Rating: Decent
7 posts
bump for justice
#107 Jul 16 2012 at 6:39 AM Rating: Good
Avatar
******
29,319 posts
kadengt wrote:
bump for justice
If you read the post before yours, you'll see that bumping isn't the way.
Dread Lörd Kaolian wrote:
PM Jerek. That will be your best bet for resolution.
If you can't figure out who that is, or how to PM him, you scroll to the bottom, find the link to "Staff List" and click the PM icon next to his name.

Or click the link I conveniently provided.
#108 Jul 17 2012 at 3:15 PM Rating: Decent
7 posts
I assumed he was talking to the guy that had a random post that had nothing to do with this thread/topic. Not me. could be wrong, and i know how to PM. lol.
#109 Jul 18 2012 at 1:35 AM Rating: Good
Avatar
******
29,319 posts
kadengt wrote:
I assumed he was talking to the guy that had a random post that had nothing to do with this thread/topic. Not me. could be wrong, and i know how to PM. lol.
I see nothing of the sort in the last couple posts, so I assume he's talking to the person who asked:
Quote:
Anyone with knowledge as to why this is going on even check this thread anymore?


And I have to assume that if you haven't PMed it's because you don't know how. Smiley: tongue
#110 Jul 23 2012 at 12:24 PM Rating: Decent
7 posts
The One and Only Poldaran wrote:
kadengt wrote:
I assumed he was talking to the guy that had a random post that had nothing to do with this thread/topic. Not me. could be wrong, and i know how to PM. lol.
I see nothing of the sort in the last couple posts, so I assume he's talking to the person who asked:
Quote:
Anyone with knowledge as to why this is going on even check this thread anymore?


And I have to assume that if you haven't PMed it's because you don't know how. Smiley: tongue



i know how, Lol. and the other guy deleted the post :P thanks though.
#113 Oct 16 2013 at 12:05 PM Rating: Decent
1 post
Is there any way to get the zam tooltips to work on a Google "Sites" website? Their editor (browser based) doesnt allow the insertion of any Java Script

Thanks
#114 Oct 30 2013 at 5:06 AM Rating: Excellent
Webmonkey
ZAM Administrator
Avatar
**
710 pandas
#115 Oct 09 2015 at 2:35 PM Rating: Decent
3 posts
Is it possible to get the js and css files for the tooltips over an https connection? I'm using ssl on my site, due to receiving sensitive information from the user, and Chrome doesn't like the fact that there's mixed content (https and plain http) on the site, so it blocks all http content -- tooltips.js and the tooltips css file(s). I don't want to have to try to restructure the site using https for ONLY sensitive input pages and http for everything else. I'd rather have https everywhere.

Any suggestions?
#116 Oct 30 2015 at 12:10 PM Rating: Excellent
Webmonkey
ZAM Administrator
Avatar
**
710 pandas
Yes. The default code we list should automatically do HTTP or HTTPS protocol based on the current page, but you can also specify HTTPS in the URL to the script if you like.
#117 Feb 22 2016 at 2:07 AM Rating: Decent
2 posts
I'm having trouble getting this to work on my asp.net based website.
On my site.master I am adding this just above the </body> tag so it is being used on every page. I have verified that the page is correctly loading the js file through developer tools in firefox.

<script type="text/javascript" src="http://zam.zamimg.com/j/tooltips.js"></script>


I am creating links dynamically and they look like this:

<a href="#" data-lucy="item=1230">Carmine Pants</a>


Now from my understanding the above link should be changed into a valid Allakhazam link but that is not happening. Instead the link remains exactly the same, and obviously does nothing when clicked and provides no tool tip when hovered over. Am I missing a step or misunderstanding the usage instructions?

Edited, Feb 22nd 2016 3:08am by Austille
#118 Feb 29 2016 at 2:36 PM Rating: Excellent
Webmonkey
ZAM Administrator
Avatar
**
710 pandas
It should provide a tooltip, but without changing the link, as the goal of that method is to let you attach tooltips to links other than the normal data pages. Can you link the page in question where it's implemented so we can see it directly?
#119 Mar 05 2016 at 10:29 PM Rating: Decent
2 posts
I have the tooltips working now, but would like to link to allakhazam over lucy.

Is there a way to link to the allakhazam page for an item using the LucyID?
Or is there an easy way I can source my database items with the "allakhazam" ID?

The problem is my database does not have the allakhazam ID and it seems I would have to manually look up and add each one?



Edited, Mar 5th 2016 11:32pm by Austille
#120 Jan 20 2017 at 4:20 AM Rating: Good
Use this tooltip meant for Lucy. Add it just before </body>
<script type="text/javascript" src="//zam.zamimg.com/j/tooltips.js?a"></script>

Then, for example, you would change:
<a href="http://lucy.allakhazam.com/item.html?id=54447">Scuffed Journeyman's Rucksack</a>

To:
<a href="http://lucy.allakhazam.com/itemraw.html?id=54447">Scuffed Journeyman's Rucksack</a>
This will keep the Lucy ID but link it to the everquest.allakhazam tooltip.

Change made = item.html to itemraw.html

____________________________
For once maybe someone would call me "sir", without adding, "you're making a scene"
#121 Jan 20 2017 at 4:23 AM Rating: Good
You can do this easily by opening your html editor and under EDIT select Find and Replace.

Edited, Jan 20th 2017 2:24am by mrduane
____________________________
For once maybe someone would call me "sir", without adding, "you're making a scene"
#122 Jan 20 2017 at 4:25 AM Rating: Good
See if the fix I just posted works for you and let me know. It's working fine for me.
____________________________
For once maybe someone would call me "sir", without adding, "you're making a scene"
#123 Apr 10 2017 at 7:48 PM Rating: Decent
1 post
Hello. I run Fanra's EverQuest Wiki - http://everquest.fanra.info - and I've been using your Tooltips for years now. Thank you for them.

However, if I view my wiki using https, the tooltips don't work. Although Jerek says, "Yes. The default code we list should automatically do HTTP or HTTPS protocol based on the current page, but you can also specify HTTPS in the URL to the script if you like.", I have been unable to get them to work.

My website uses MediaWiki. Here is the code I use in VectorTemplate.php right above </body>:

  <script async type="text/javascript" src="//zam.zamimg.com/j/tooltips.js"></script> 
  <script async>var zam_tooltips = { "iconizelinks": true }</script> 


I've tried variations of this involving https://zam... and http://zam.. (with and without the async, if case someone thinks that could be the issue) and so on, but none seem to work.

I do use Cloudflare to get the HTTPS to work, as I don't have my own SSL certificate. HTTPS seems to work fine, except when calling javascript from another website, like ZAM.

Please let me know if there is any way to get this to work.

Thank you for your help in this matter.

Edited, Apr 10th 2017 9:50pm by Fanra

Edited, Apr 11th 2017 2:34pm by Fanra
____________________________
Fanra
EverQuest Druid
everquest.fanra.info
#124 Apr 11 2017 at 6:16 PM Rating: Excellent
Fanra, I'll bring this up with our developer soon. He will be busy working on a project here soon so at some point after that I'll bring this to his attention.
1 2 3 Next »
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 35 All times are in CDT
Anonymous Guests (35)