Forum Settings
       
« Previous 1 2 3 4 5
Reply To Thread

Tooltips FeedbackFollow

#1 Dec 21 2007 at 3:32 PM Rating: Excellent
Bad j00 j00
Avatar
***
2,159 posts
You can add ZAM database tooltips on any site!

For the details on how it is done, [link=/enhancements.html]see this page[/link]. It is simple to do and requires no programming experience or knowledge. For details on other sites select one from the dropdown in the top-right.

If you have any feedback or questions, please post them here.

Edited, Dec 21st 2007 6:34pm by Nizdaar

Edited, Mar 29th 2012 11:08am by Jerek
#2 Dec 22 2007 at 4:32 PM Rating: Good
***
2,793 posts
Slight problem viewing things.
http://i9.tinypic.com/8293lf7.jpg
____________________________
The FFXI "community" needs an enima. If you doubt this, look at the forums on BG, ffxiah, and alla. If you STILL doubt this, visit 4chan. Note the similarities. Then light yourself on fire.

#3 Dec 22 2007 at 5:15 PM Rating: Excellent
Bad j00 j00
Avatar
***
2,159 posts
If you hold down shift and press reload, it'll go away. Your browser caches the .js file for a while. I fixed that problem last night. It was annoying, along with a few other annoying side effects. Thanks for the bug report though!
#4 Dec 22 2007 at 5:56 PM Rating: Good
***
2,793 posts
You rock, Niz
____________________________
The FFXI "community" needs an enima. If you doubt this, look at the forums on BG, ffxiah, and alla. If you STILL doubt this, visit 4chan. Note the similarities. Then light yourself on fire.

#5 Dec 28 2007 at 7:17 AM Rating: Excellent
***
3,937 posts
How hard would it be to extend these to work with lucy.allakhazam?

Lucy item numbers correspond with actual ingame item #'s whereas the main site's are arbitrary, so being able to link based off of lucy numbers would make it easier to integrate with dkp systems and similar stuff.
#6 Dec 28 2007 at 8:42 AM Rating: Excellent
Bad j00 j00
Avatar
***
2,159 posts
Not very hard at all. I have a new version going that is going to enable mouseovers for our wikis as well.
#7 Dec 29 2007 at 6:51 AM Rating: Default
49 posts
Having a problem with the pop-up type tooltips. When I 'mouse over' a link for an item, and the tooltip pops up, it popsup over and over and over again, sorta like some pop up blocker is shutting it down, but it pops back up again. Makes it almost impossible to click on a link to a piece of gear now. I use Firefox with pop up blocker. I dont' want to shut that off, is there a way to turn off the tooltip pop-ups from Alla? Seems to be doing the same thing on other Alla sites too, like EQ2, but weird not on WOW site.

Edited, Dec 29th 2007 9:59am by Blabberpuss
#8 Dec 29 2007 at 9:04 PM Rating: Excellent
Bad j00 j00
Avatar
***
2,159 posts
Blabberpuss wrote:
Having a problem with the pop-up type tooltips. When I 'mouse over' a link for an item, and the tooltip pops up, it popsup over and over and over again, sorta like some pop up blocker is shutting it down, but it pops back up again. Makes it almost impossible to click on a link to a piece of gear now. I use Firefox with pop up blocker. I dont' want to shut that off, is there a way to turn off the tooltip pop-ups from Alla? Seems to be doing the same thing on other Alla sites too, like EQ2, but weird not on WOW site.

Edited, Dec 29th 2007 9:59am by Blabberpuss


What browser, operating system and screen resolution are you using?
#9 Dec 30 2007 at 12:55 PM Rating: Default
49 posts
FIREFOX

XP sp2

1280 x 1024
#10 Jan 04 2008 at 9:45 AM Rating: Default
49 posts
I noticed something about this today, the popup tooltip item descriptions are not being blocked, what is happening is that when the popup comes up, it shifts the page formatting and drives the page downwards forcing my mouse pointer over a different item, forcing a different popup tooltip to open, rinse and repeat. Did that make sense?
#12 Aug 08 2008 at 3:33 AM Rating: Decent
33 posts
How to I use this in conjunction with ItemStats? I'm running a FFXI EQDKP page and I want to use the tool tips for the gear that drops. It works for wow but I can't figure out how to make it work for Final Fantasy. Here is the link to the config file: http://itemstats.free.fr/e107_plugins/content/content.php?content.8
____________________________
Name:Antonioklaus| Race:Hume | Server:Leviathan | Nation:San D'Orian-Rank 10
Jobs:WHM-75 | BRD-75 | SMN-75 | BLM-75 | NIN-58 | RDM-75 BotD - SKY/HNMLS | Beacon - Dynamis
Crafting:Cooking - 100+5 | Fishing - 62 | Woodworking - 60 | Leather - 2
Avatars: Carbuncle | Shiva | Ifrit | Garuda | Ramuh | Leviathan | Fenrir | Diabolos
#13 Sep 12 2008 at 6:54 AM Rating: Decent
2 posts
Hi people of Allakhazam.
I'm setting up a new site for our Lotro Kinship and I ran into your tooltip script.
So I added it and it did not work.
After a short bit of thinking I came up with the following:
JS-calls should go into the head and not into the body, as stated on the wiki page! (maybe a good idea to change this?)

Anyway, I changed it to be in the head, but it still does nothing.
Link
Here you can see it not working, look at the newsitem "Test for showing items on our website."
I linked a weapon there.
(don't look at the rest of the newsitems, their still standard :))

If you wish you can also view the page source, where you will see that it is in the right place, right under the standard javascript-calls.

Any idea what this could be?

Thanks in advance, Rienko

Oh yeah, I'm using Joomla 1.5.

-----------------------------------------------------------------------

And I just, thanks to firefox web developer, I just found out where the problem might about be.
It returns this error:
-----------
Error: p is undefined
Source File: http://common.allakhazam.com/shared/akztooltip.js
Line: 21
-----------
Perhaps I do call it in a wrong way?
Or some things in Joomla don't want to work with the way the script is written?

Edited, Sep 12th 2008 10:54am by Rienkoo
#14 Sep 18 2008 at 4:26 PM Rating: Excellent
Bad j00 j00
Avatar
***
2,159 posts
Rienkoo,

It isn't working because you put the <script> tag in side the head. In order for the tooltips to work the head has to be fully loaded so it can add a call to the tooltip css. I saved a copy of your front page to my hard-drive and moved the akztooltips.js script call to just before the end of the body and it worked fine.

-Niz

Rienkoo wrote:
Hi people of Allakhazam.
I'm setting up a new site for our Lotro Kinship and I ran into your tooltip script.
So I added it and it did not work.
After a short bit of thinking I came up with the following:
JS-calls should go into the head and not into the body, as stated on the wiki page! (maybe a good idea to change this?)

Anyway, I changed it to be in the head, but it still does nothing.
Link
Here you can see it not working, look at the newsitem "Test for showing items on our website."
I linked a weapon there.
(don't look at the rest of the newsitems, their still standard :))

If you wish you can also view the page source, where you will see that it is in the right place, right under the standard javascript-calls.

Any idea what this could be?

Thanks in advance, Rienko

Oh yeah, I'm using Joomla 1.5.

-----------------------------------------------------------------------

And I just, thanks to firefox web developer, I just found out where the problem might about be.
It returns this error:
-----------
Error: p is undefined
Source File: http://common.allakhazam.com/shared/akztooltip.js
Line: 21
-----------
Perhaps I do call it in a wrong way?
Or some things in Joomla don't want to work with the way the script is written?

Edited, Sep 12th 2008 10:54am by Rienkoo
#15 Nov 01 2008 at 7:41 AM Rating: Decent
2 posts
Wow yeah, I indeed now put it just before the [/body] and it works terrificly.
I think I thought about it too deep or something, like normally scripts should be in the head :D
Thanks a million for the answer.
And especially thanks for making this script, it's a very nice addition.

Late post btw, haven't been working on the site for just some time :D
Just got back to it and remembered I posted here.

Edited, Nov 1st 2008 11:43am by Rienkoo
#18ClementTheLight, Posted: Apr 25 2009 at 11:15 AM, Rating: Sub-Default, (Expand Post) so the new Zam site is on, hows the new tooltip working?
#19 May 02 2009 at 3:46 AM Rating: Decent
18 posts
Ok - it seems that Allakhazam's is ZAMS (now??) Anyhow, the EQ2 site (IMHO) needs alot of work - it's alot worse then it was prior, but that's beside the point here...

My main question is about the TOOLTIP pop-ups for guild websites - it seems that the TOOLTIPS don't work any longer. They seem to work for all other MMOGs, except EQ2. I have tried to point them to a 'new' ID (Which it seems everything was reassigned on EQ2 ZAM site) but that doesn't work....

Is there any plan to bring back or could you point me to the correct TOOLTIP? I Have <script type="text/javascript" src="http://common.allakhazam.com/shared/akztooltip.js"></script> and it isn't working....


~Draylor
#20 Aug 14 2009 at 12:54 AM Rating: Decent
3 posts
According to this the script for EQ2 is supposed to be
 
<script type="text/javascript" src="http://common.zam.com/shared/zampower.js"></script>  

as you have found out already. Me was looking for the same :-) Would be nice if the http://www.allakhazam.com/wiki/tooltips would reflect the change also.
#21 Jul 22 2010 at 6:07 AM Rating: Decent
2 posts
Quote:
Everquest and Lucy

To use the game id/lucy id for a tooltip instead of the allakhazam id simply add source=lucy

* Templar of Fright Bracer


Everquest and Lucy items are not linking up anymore. Even the example on the ZAM Tooltip page is not working correctly.
#22 Aug 13 2010 at 6:47 PM Rating: Good
Anterograde Amnesia
Avatar
*****
12,363 posts
Trying to incorporate this into my Windows Gadget. I get an error at this part:

 
function addAkzElement(p,element) { 
   return p.appendChild(element); 
}  


Says p is undefined in Firebug.
____________________________
"Choosy MMO's choose Wint." - Louiscool
The greatest trick the devil ever pulled was to convince the world he didn't exist.
Keyser Soze - Ultros
Guide to Setting Up Mumble on a Raspberry Pi
#23 Aug 15 2010 at 1:18 PM Rating: Decent
7 posts
hello Nizdaar, and everyone else.

I think this is simply an amazing item to use. I am running a site + forum and i was wondering how to get this into my site. I know what i have to add, but the site is made from Wordpress. if I cannot add it to that is there a way to add it to my forum at all? I am using IPB 3.1.x

If you need any other info i can pm you with it if need be.


Thank you,
Kaden
#24 Aug 17 2010 at 2:35 PM Rating: Excellent
Webmonkey
ZAM Administrator
Avatar
**
710 pandas
kadengt wrote:
I am running a site + forum and i was wondering how to get this into my site. I know what i have to add, but the site is made from Wordpress. if I cannot add it to that is there a way to add it to my forum at all? I am using IPB 3.1.x

You'll probably need to edit the footer templates for Wordpress and IPB to add the <script> bit. I'm not very familiar with those software packages but that can probably be done in their admin areas.
#25 Aug 18 2010 at 5:10 PM Rating: Decent
2 posts
In super lame man terms where do i paste this <script type="text/javascript" src="http://common.allakhazam.com/shared/zampower.js"></script>
Can you just pm me this info please , thank you



Edited, Aug 18th 2010 7:15pm by Nice1Evil1
#26 Aug 19 2010 at 8:42 AM Rating: Good
Avatar
****
4,150 posts
Is it possible to get this to work on a Proboards site? I listed some of the items for FFXIV, and I'd like to have the tooltips show up.
____________________________
FFXI-Garuda 2003-2009; Lakshmi 2011-8/20/13 (retired)
FFXIV: ARR - Ghost Bear, Balmung server
« Previous 1 2 3 4 5
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 42 All times are in CDT
Anonymous Guests (42)