Forum Settings
       
Create Thread
Subject Started by Replies Views Last Post
OC and Average Temps. Wloire 5 1,582 Aug 10 2010 by Majivo
PS3 is dying, any advice? PigtailsOfDoom 6 1,582 Aug 08 2010 by SamusKnight
hey what'dya know, a comp question (was forum=10) Nilbog 9 2,124 Aug 06 2010 by Enscheff
Any comments on my $1000 FFXIV rig? First Time Builder. rsrlawman 5 1,864 Aug 06 2010 by Enscheff
I'm having trouble setting up a FFXI PlayOnline account. Caillron 2 2,616 Aug 06 2010 by catwho
FFXIV Startup Error P00f 3 5,828 Aug 05 2010 by Linku
FFXI Connection Probs Actionjakson 6 2,052 Aug 04 2010 by Linku
FFXI Update just stops. Help please! bianx 0 1,328 Aug 03 2010 by bianx
hard drive issue rosleck 4 1,198 Aug 02 2010 by Alobont
Registry cleaners rosleck 2 1,289 Aug 01 2010 by seneleron
Daemon Tools Code Error 14 blackeyes01 0 1,842 Jul 31 2010 by blackeyes01
FFXIV FPS / Benchmark Calculator zwinkletoes 0 3,401 Jul 28 2010 by zwinkletoes
ffxi crashes on loading screen after selecting character Supersabes 5 4,090 Jul 23 2010 by Berezo
FFXIV Benchmark has stopped working, advice? (was forum=29) Warriorxx 3 8,642 Jul 23 2010 by marineman
I need help with a virus problem. Here's A hijackthis! log Driftwood 5 1,679 Jul 16 2010 by Dread Lörd Kaolian
Computer Lag(FFXI) order 8 2,900 Jul 15 2010 by Alobont
Motherboard Information. Wloire 15 2,219 Jul 12 2010 by Wloire
New laptop, ffxi, and windows 7 rootcow2 8 3,306 Jul 10 2010 by Shaowstrike
removing a raid set up rosleck 2 1,272 Jul 08 2010 by Levish
Skips, freezes, and blue screens, oh my Catwho 6 1,443 Jul 06 2010 by catwho
Use internet explorer? xthunderblazex 5 1,405 Jul 04 2010 by xthunderblazex
High Temperature, Pentium D Ehcks 4 1,475 Jul 04 2010 by xthunderblazex
4 FPS on a brand new MBP help please! (was forum=28) Axenrot 7 1,730 Jul 04 2010 by xthunderblazex
Computer Problems, Please Help. (was forum=10) dmhlucky 11 2,879 Jul 02 2010 by dmhlucky
p4 Hd3650 jam alexkolwitz 7 2,132 Jul 01 2010 by Isiolia
Ventrilo forums (was forum=21) (was forum=22) CestinShaman 2 2,130 Jun 29 2010 by IDrownFish
Moved - Alla won't load at home... Likibiki 0 1,269 Jun 28 2010 by Likibiki
Transferring PC case Raiziell 5 1,600 Jun 27 2010 by Agamemnos
Chrome posting issues. Raelix 1 1,694 Jun 27 2010 by Eske
New Rig -- Graphics card? cinotech 2 1,785 Jun 26 2010 by cinotech
Trouble downloading WOWReader dchantlos 1 1,534 Jun 22 2010 by Kastigir
Considering building a new rig.. Majivo 6 1,539 Jun 22 2010 by Majivo
FFXI crashes when I zone. LoricSiroccotheMostAmazingMan 5 2,409 Jun 18 2010 by Alobont
PC Freezing Doug 21 2,184 Jun 18 2010 by Alobont
Command and Conquer 4: Black/Blank Screen Crashing MagingMartin 1 2,747 Jun 18 2010 by Alobont
FFXI version update communication error amadeo17 1 2,822 Jun 18 2010 by Alobont
Gmail Account Warning (was forum=10) EndlessJourney 24 3,987 Jun 16 2010 by Eske
Create Thread
Recent Visitors: 12 All times are in CDT
Anonymous Guests (12)