Forum Settings
       
« Previous 0 Next »
Reply To Thread

Razer Lachesis issue after Windows 7 updatesFollow

#1 Jan 26 2012 at 11:29 PM Rating: Good
The last two times Windows 7 has done the auto download and install of their updates, my Razer Lachesis (the 4000 version) has had function issues. Basically, after shutting the computer down, and then starting it back up again, the mouse will work fine for a while (say an hour or so) and then suddenly none of the buttons are responsive. The lights from the middle button and the Razer logo will flash, and the cursor won't move until the lights stop flashing.

Unplugging and replugging in the mouse doesn't work, even using different USB ports. I have also tried uninstalling and reinstalling the drivers and firmware on the suggestion of the Razer support via phone, so I know I have the drivers and such up to date.

Randomly, it will start working again, and then later it stops working again. Last time this happened, the mouse stopped having the issue after a day or two. I only just did the 7 updates this morning, so it may stop having this issue in a couple days, but I'd really like to figure out why it does this after updating Windows 7, and prevent it from happening in the future.
____________________________
Proudmoore US server:
Popina, 90 Priest
Digits, 86 Shaman
Thelesis, 85 Mage
Willowmei, 85 Druid
Necralita, 85 DK
Shrika, 72 Warlock
Jaquelle, 54 Paladin
Grakine, 32 Hunter
The MMO-Zam's FB group. Please message me first so I know who you are.
« Previous 0 Next »
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 20 All times are in CST
Anonymous Guests (20)