Forum Settings
       
Reply To Thread

Help, my new laptop is not working with Rift =(Follow

#1 Mar 01 2011 at 11:50 PM Rating: Decent
9 posts
So, I just bought a M15x alienware from dell with 6 GB of ram so I could play Rift and pvp.It has an ATI Mobility Radeon HD 5850. Whenever I get to an endzone boss or try to pvp I lag uncontrollably. My brother's laptop, which is years older, runs better on the same internet connection.

So I figure it's a driver issue? I can't possibly think of what else it might be and I really don't want to believe it's the machine already since I've had it less than a week. I updated to the 8.763 drivers off the dell site (because the alienware site redirected me there). It says the last time they updated them is September. Are these the right drivers? Can anyone help me figure out what I can do to get past 10 FPS (which drops even LOWER in pvp?)

I'm very frustrated.
#2 Mar 01 2011 at 11:59 PM Rating: Decent
9 posts
just to eliminate a few of the other questions people might have as to assessing my problem -

-I'm running my laptop at high performance.
-It is plugged in and not a power issue.
-Magicka runs fine but I don't have any other high demand games on it besides Rift to test the issues I'm having with it.
#3 Mar 02 2011 at 1:07 AM Rating: Excellent
Avatar
******
29,905 posts
It's not just you, and it's not just your hardware. There appear to be several dozen threads similar to this one: http://forums.riftgame.com/archive/index.php/t-52698.html?s=a15147dbdc6a83bcc52f9d040311ab8d where people are complaining of extremely low end performance specifically with that card. My best guess is its a game engine bug that they haven't noticed / got to yet. I don't have any decent fixes yet other than to tell you its not uncommon for games such as this to have laptop video card issues at launch and it will probably get better soon. Not really helpful, i know.
____________________________
Arch Duke Kaolian Drachensborn, lvl 95 Ranger, Unrest Server
Tech support forum | FAQ (Support) | Mobile Zam: http://m.zam.com (Premium only)
Forum Rules
#4 Mar 02 2011 at 7:08 AM Rating: Decent
9 posts
thank you for the reply. Arg... now what to do!
#5 Mar 02 2011 at 8:01 AM Rating: Decent
Scholar
***
1,150 posts
Dell owns Alienware now which is why it has gone to crap.

If your drivers are from September I can see where that would be a problem. ATI made a number of changes since then. Please read http://support.amd.com/us/kbarticles/Pages/AMDCatalyst112ReleaseNotes.aspx After reading this you can try the new drivers if you want. The good news is Alienware/Dell is not on the explict do not use list. Just realize you mave to revert to the Dell drivers.

If that doesn't work for you then try the low res version.
#6 Mar 02 2011 at 12:11 PM Rating: Good
Terrorfiend
*****
12,905 posts
I heard in Rift chat last night somebody say they had a huge performance increase with their ATI card. Have you tried it out today?
#7 Mar 02 2011 at 10:51 PM Rating: Decent
9 posts
I updated to the catalyst drivers. With them set to run max performance over quality and setting Rift to low rendering I'm up to 25 fps while soloing. Of course I still can't pvp but it's a slight improvement. At least I can level! lol =(
#8 Mar 03 2011 at 8:14 AM Rating: Good
Scholar
***
1,150 posts
Do you have anything using flash in the back ground (youtube)? If so kill it or turn off hardware acceleration.

Check how much bloatware you have running while rift is running. Most of it may be running when your computer starts.

Do not have CCC decided anything about how the game runs. Set everything to be decided by application. Head over to the official forum and read the know issue list and make changes as needed.
#10 Dec 22 2011 at 3:44 AM Rating: Decent
2 posts
I found this very helpful at least for everquest..

if you have a Ricoh xD-Picture Card Controller try disabling the driver while in game.. your performance should immediatly improve if this is the issue. Worked for me on my alienware m15x
For details check out this post

http://forum.notebookreview.com/alienware/464454-m17x-poor-performance-high-cpu-usage-interrupts-solved.html
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 19 All times are in CST
Anonymous Guests (19)