Forum Settings
       
Reply To Thread

FFXI (yes eleven) New Acct IssuesFollow

#1 Aug 20 2010 at 4:05 PM Rating: Decent
*
69 posts
I'm not ultimately sure whether this belongs here or in the FFXI General forum. So please forgive me if this should be scooted elsewhere.

I bought FFXI on steam for 10 bucks about 3 weeks ago now, as I hadn't played since ToAU and it was actually cheaper to just buy the bundle than the expansions I was missing. It was also helpful since I no longer have my old account information.

The problem is that I can't create a new account. My Mastercard is registered for the securecard system as is required. I get to the registration having me open a new tab and authenticate my card (and it is successful). But the 1 dollar "temp charge" doesn't ever show up on my online billing (like other test purchases do).

I've contacted my bank (fifth third) and they've assured me that it's not an issue on their end. I've also contacted S-E's customer service and was told that the servers were congested (hence my 60257 code) and to try again later. They also said to check with the bank (which I've done). I've tried multiple times(with 30 minute delays between), almost daily for the past 3 weeks to just setup an account.

The only other person I know that used to play using a PS2 can't help as his PS2 died so that method is out.

Basically, are there any suggestions. I've also tried other cards with no luck and continual "server is congested" codes. I've never had to put so much effort for someone to take my money.
____________________________
Game: FFXI
Server: Ragnarok
Character: AcidReign
Primary Job: Samurai
Status: Retired (2008)
#2 Sep 02 2010 at 2:59 PM Rating: Decent
I've been having the same problem for about a week now. Did you find a solution or get through?
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 38 All times are in CDT
kaludas07, Poldaran, Szabo, Anonymous Guests (35)