Forum Settings
       
Reply To Thread

Video driver suggestionFollow

#1 Mar 24 2009 at 1:15 AM Rating: Decent
Scholar
**
308 posts
Might someone be able to suggest a driver for a Radeon x1650 that will get along with XI? Neither the drivers that came on the disk nor the newest one get along with my computer very well. They also seem to cause problems with browsing and just generally slow down my computer. I have the older style of video card if that matters.

Thank you for looking
#2 Mar 24 2009 at 4:27 PM Rating: Good
Scholar
***
2,638 posts
I used to own a X1650.

Try the Catalyst 7.5 or if youre on Windows XP try the 5.13
____________________________
The Lakshmi Coomunity!
http://ffxilakshmi.com/

Tenmiles wrote:
I am officially voting Shykre from now on.

lolgaxe wrote:
shykre wrote:
Vote Shykre for Player of the Month!
#3 Mar 25 2009 at 2:09 AM Rating: Decent
Scholar
**
308 posts
I do have XP and thank you for the suggestion. However, not to be dense, but I can't seem to actually get the driver to install on my computer. I get an IFP error and it stops the installation. Does the same thing in safe mode.

#4 Mar 25 2009 at 5:00 AM Rating: Good
Scholar
***
2,638 posts
Have you removed your drivers prior to uninstall?

Also which version or maker of the X1650 do you have?

____________________________
The Lakshmi Coomunity!
http://ffxilakshmi.com/

Tenmiles wrote:
I am officially voting Shykre from now on.

lolgaxe wrote:
shykre wrote:
Vote Shykre for Player of the Month!
#5 Mar 25 2009 at 10:44 AM Rating: Decent
Scholar
**
308 posts
SAPPHIRE 100175L Radeon X1650PRO 512MB 128-bit GDDR2 AGP is my video card. And the driver is off. I get the new hardware wizard pop up when I start my computer.

Running setup from the 5.13 folder gives me an 'INF error, video driver not found' pop up.

Edit: I wasn't able to get 5.13 on but I think the driver from Sapphire is working. Thank you very much for the suggestion though ^^

Edited, Mar 26th 2009 2:32pm by SeraphOwl

Edit #2: Okay it looked good but freaked out when I loaded a game. But it seems maybe catalyst was the culprit. So much trouble just installing a driver o.O;

Edited, Mar 27th 2009 3:27am by SeraphOwl
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 15 All times are in CDT
Anonymous Guests (15)