Forum Settings
       
Reply To Thread

Please help with the Sony StationFollow

#1 Dec 24 2010 at 8:55 PM Rating: Decent
*
108 posts
I installed the game and used the activation code. Then it was showing me it was updating the game, but now every time I try to launch it, it asks me to buy one of the bundles, even after I put the code in the Sentinel's Fate CE. Also I have no clue how to see if it is updating. I can not launch nor do anything without them wanting me to buy something can you please help?
____________________________
Gundarius- Level 60 Retribution Blood Knight- Ghostlands
Hanafuda- Level 60 Frost Death Knight- Ghostlands
#2 Dec 24 2010 at 10:02 PM Rating: Excellent
Empress of News
ZAM Administrator
Avatar
***
2,219 posts
I think you can just choose to skip the page you're talking about, mine even does that despite activating every expansion seperately.

Do you know which launcher you're using? (streaming, launchpad, station launcher, etc) I'm personally using the Station Launcher so I'm not completely sure how you can tell whether or not the streaming one is downloading.

Also might want to search topics on the soe tech support boards, possible that someone else has seen the bundle issue: http://forums.station.sony.com/eq2/forums/list.m?category_id=45
#3 Dec 25 2010 at 12:16 PM Rating: Decent
*
108 posts
I found out the problem, on the box it says 30 days free but you also have to input CC info to activate the free Sub, thank you for the help though, Merry Christmas.
____________________________
Gundarius- Level 60 Retribution Blood Knight- Ghostlands
Hanafuda- Level 60 Frost Death Knight- Ghostlands
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 34 All times are in CST
Anonymous Guests (34)