Forum Settings
       
« Previous 1 2
Reply To Thread

WarReader HelpFollow

#1 Sep 15 2008 at 8:35 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
Please post any issues or problems you have with WARReader here.

Edited, Sep 16th 2008 12:38am by Nizdaar

Edited, Sep 16th 2008 2:15am by Nizdaar
#2 Sep 15 2008 at 8:55 PM Rating: Excellent
***
1,086 posts
You can also review what the warreader is all about through the link above as well. If you have any further questions, reply here please!
#3 Sep 17 2008 at 10:37 AM Rating: Decent
1 post
I'm getting the following error, when trying to upload using war reader:

The remote server returned an error: (407) Proxy Authentication Required.

I don't see anywhere in the Settings, that would allow me to authenticate.

Edited, Sep 17th 2008 2:36pm by Greysyn
____________________________
Greysyn lvl 50 Briton/Crush Mercenary/Merlin [Dark Age of Camelot]

Greysyn lvl 70 Night Elf/Rogue/Bleeding Hollow [Twilight Guard]

Greysyn lvl 15 High Elf/Shadow Warrior/Skull Throne [Myth]
#4 Sep 17 2008 at 3:26 PM Rating: Good
Hi Greysyn,

One of the devs can probably comment on this, but...
It's my understanding that warreader uses the proxy settings from Internet Explorer's Internet Options. If your proxy server requires authentication, you'll probably need to:

1) Make sure that IE is set to authenticate and save your u/p for your proxy server.
2) If you're using some crappy software proxy, stop.
3) You may need to make some registry entries with your proxy settings...but I sure as heck can't comment on those.

-T.

____________________________
[wowsig]934431[/wowsig]

http://www.void-if-removed.com

"T. I hope you tell everyone you have ever ganked..."You've just been ganked by a left handed arthritic rouge. Have a nice day."

That would be epic." -Xlemage
#5 Sep 17 2008 at 4:11 PM Rating: Decent
****
5,644 posts
Tepetkhet the Shady wrote:
Hi Greysyn,

One of the devs can probably comment on this, but...
It's my understanding that warreader uses the proxy settings from Internet Explorer's Internet Options. If your proxy server requires authentication, you'll probably need to:

1) Make sure that IE is set to authenticate and save your u/p for your proxy server.
2) If you're using some crappy software proxy, stop.
3) You may need to make some registry entries with your proxy settings...but I sure as heck can't comment on those.

-T.


people still use IE?
#6 Sep 17 2008 at 5:15 PM Rating: Good
I misspoke, really.
It's the Internet Options in the OS, the same ones that IE uses.

-T.
____________________________
[wowsig]934431[/wowsig]

http://www.void-if-removed.com

"T. I hope you tell everyone you have ever ganked..."You've just been ganked by a left handed arthritic rouge. Have a nice day."

That would be epic." -Xlemage
#7 Sep 21 2008 at 9:15 AM Rating: Good
***
2,824 posts
Quote:
syntax error, unexpected '='Error uploading lua


That's what I'm getting atm. Should I just delete the file and start a new one?
#8 Sep 21 2008 at 1:57 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
baelnic wrote:
Quote:
syntax error, unexpected '='Error uploading lua


That's what I'm getting atm. Should I just delete the file and start a new one?


Can you email me your SavedVariables.lua file to nizdaar@allakhazam.com, please? have you tried restarting warreader?
#9 Sep 22 2008 at 1:47 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
Nizdaar wrote:
baelnic wrote:
Quote:
syntax error, unexpected '='Error uploading lua


That's what I'm getting atm. Should I just delete the file and start a new one?


Can you email me your SavedVariables.lua file to nizdaar@allakhazam.com, please? have you tried restarting warreader?


This should be fixed, now.
#10 Sep 22 2008 at 3:31 PM Rating: Good
***
2,824 posts
Thanks.

I know this isn't the place, but can I have a WAR sig so I can renew Premium? Any news on that front?

Edited, Sep 22nd 2008 5:26pm by baelnic
#11 Sep 24 2008 at 5:05 AM Rating: Good
******
26,516 posts
Is there any chance that the WARReader can work similar to the WoWreader? Where starting up the WARReader can also be used as a portal to start WAR? I like that I only have to have the WoWreader Icon on my desktop which allows me to start up the reader, and start up WoW, but with WAR, I have to keep the WARReader icon and the actual Warhammer start icon on my desktop. Or am I missing something?

It's a small nagging concern of mine. :D
____________________________
WILL SHOWER AND POST PICS FOR GURU
#12 Sep 25 2008 at 9:05 PM Rating: Decent
2 posts
is there any alternative download location? i can't get it from http://lucy.allakhazam.com/warreader-inst.exe and google searches only come back to here
#13 Sep 26 2008 at 4:47 AM Rating: Good
**
459 posts
I have a question. Is there any way to check how many files you've uploaded or anything like that? I run WarReader constantly, but since there is no upload function or anything available, I'm not even sure it's working. I'd settle even for a green "working" light or something. I just want to be sure I'm doing it right and contributing my bit to the database properly.
____________________________
[wowsig]1939433[/wowsig]
#14 Sep 26 2008 at 3:26 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
Licktoren wrote:
is there any alternative download location? i can't get it from http://lucy.allakhazam.com/warreader-inst.exe and google searches only come back to here


That is the only place to download it from.
#15 Sep 26 2008 at 3:27 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
BethelRose wrote:
I have a question. Is there any way to check how many files you've uploaded or anything like that? I run WarReader constantly, but since there is no upload function or anything available, I'm not even sure it's working. I'd settle even for a green "working" light or something. I just want to be sure I'm doing it right and contributing my bit to the database properly.


After you've uploaded data, it will display done in the uploaded column. Soon I'll have a page up that shows people's contributions.
#17 Sep 27 2008 at 12:13 AM Rating: Good
**
459 posts
Well see, the problem is there IS no option to upload data anywhere I can find. The only option under "File" is Exit, and the two options under Settings are Login (done) and Set Warhammer Path (also done). That's part of what is so confusing to me and why I can't tell if it's doing anything at all.
____________________________
[wowsig]1939433[/wowsig]
#18 Sep 27 2008 at 7:42 AM Rating: Excellent
***
1,086 posts
It uploads automatically upon exit of the game. Just ensure the warreader has your login information for Allakhazam and you're good to go. If you watch the warreader immediately upon exit of the game you can see it upload and then "done".

Thanks for helping out!
- Berek
#19 Sep 27 2008 at 8:57 AM Rating: Good
**
459 posts
I'll believe you if you say so, but I have watched it and it doesn't upload, nor does it say done. The only thing it ever says is "SavedVariables.lua - - no" Where "no" is under the uploaded heading.
____________________________
[wowsig]1939433[/wowsig]
#20 Sep 27 2008 at 12:32 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
Under settings is 'Set Warhammer path', is it pointing to the warhammer directory? If not it needs to be.
#21 Sep 27 2008 at 1:07 PM Rating: Good
**
459 posts
DOH! Thanks guys, I rechecked the file location, and I guess it was going to the wrong directory (I recently had a major computer meltdown and I'm still trying to restore/replace/find stuff) and I apparently have TWO Warhammer directories right now. And the WarReader was attached to the wrong one that I wasn't using.

Thanks awfully for the help and the patience with my brainfarts and helping me to get it working!
____________________________
[wowsig]1939433[/wowsig]
#22 Sep 28 2008 at 3:13 PM Rating: Good
46 posts
BethelRose wrote:
I'll believe you if you say so, but I have watched it and it doesn't upload, nor does it say done. The only thing it ever says is "SavedVariables.lua - - no" Where "no" is under the uploaded heading.


I'm having the same problem on my machine. Windows Vista (32bit). It hasn't uploaded a thing ever always says No and never has a file size either. File path is set properly as well. On my xp notebook it works fine. Unfortunately I am using UAC as I have a couple of programs for work that require UAC to be active or they won't run properly. So If it requires UAC to be off you're going to be of luck.

Edited, Sep 28th 2008 11:08pm by gror
#23 Oct 01 2008 at 9:51 PM Rating: Decent
5 posts
Can the WarReader be used on the EU servers?

I seem to remember from my WoW days that the reader did not work on the EU servers.
#24 Oct 02 2008 at 3:09 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
WarReader can be used on EU servers. Right now I'm only parsing english submissions. I am however storing other languages in case in the future we support locales other than enUS/enGB.
#25 Oct 03 2008 at 8:36 AM Rating: Good
46 posts
Any clue as to why this won't run on a Vista OS (32 bit) using UAC (yes I hate it but as I said 2 posts up it's necessary for me.)?
#26 Oct 07 2008 at 1:56 PM Rating: Good
***
2,824 posts
Just noticed that WarReader is tracking where I drop our standard :P

http://war.allakhazam.com/db/mob.html?warmob=9026

It's pretty cool, but probably not intended or necessary.

Unless you guys are trying to track me ingame! >.>
#27 Oct 07 2008 at 5:14 PM Rating: Decent
The remote server returned an error: (502) Bad Gateway.

or

The operation timed out.

I checked the path and login info they are both correct, Norton dosn't seem to be giving it a problem but I added the warreader executable to the allowed list anyway.
#28 Oct 08 2008 at 10:55 AM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
There's a known issue where processing the uploaded data can take too long and a timeout occurs. No data is lost but the WarReader client reports an error when there really wasn't one. I'll try to get that fixed in the next week or so.

We're tracking standards as well? As awesome as that sounds, it's not something we really want to do. I'll look into it.
#29 Oct 15 2008 at 12:39 AM Rating: Decent
3 posts
Whiteblade wrote:
The remote server returned an error: (502) Bad Gateway.

or

The operation timed out.

I checked the path and login info they are both correct, Norton dosn't seem to be giving it a problem but I added the warreader executable to the allowed list anyway.


That happened to me, first the Bad Gateway, then Timed Out... I just kept pressing retry when it failed, eventually it worked :)
#30 Oct 15 2008 at 1:06 PM Rating: Decent
2 posts
i have the problem "SavedVariables.lua uploaded NO"

The path is right, the password is right but it always says "NO" under upload.

Any idea or suggestion?
#31 Oct 23 2008 at 10:37 AM Rating: Decent
1 post
I am also getting the same issues described above and get no in the window on vista 32
#32 Oct 24 2008 at 6:56 AM Rating: Decent
2 posts
same issues, it seems as if the warreader doesn't do anything except take up memory and disk space.

next update make it give an onscreen notification or something shows up in the system tray to show when its doing something.
#33 Oct 24 2008 at 12:10 PM Rating: Decent
Scholar
23 posts
"SavedVariables.lua - - no" Thats all I ever see. I am on XP Pro, correct password and correct file directory yet it never changes. I am sure its got info, my SavedVariables.lua is 10.5 meg. I want to upload it so I can delete it and clean it up, but it wont upload for me, am about to give up and uninstall it. So please any info would be helpful.

Edited, Oct 25th 2008 4:15am by Raygar
#34 Oct 24 2008 at 12:31 PM Rating: Decent
2 posts
is there a way that you can have it report what the Warped, Wrecked, and other repairable items turn into after being repaired, because i have several that are not for my class and would like to send to alts, but do not know which class can use it as it won't let me repair it to find out or tell me what class it is for.
#35 Oct 24 2008 at 5:57 PM Rating: Decent
Scholar
23 posts
Hell I just want it to work period.

Edited, Oct 25th 2008 4:08am by Raygar
#36 Oct 25 2008 at 12:06 AM Rating: Decent
Scholar
23 posts
Question, is there a way to upload it without using warreader? Seeing as how it doesn't work for a bunch of us it seems. I can at least upload my info before I delete a mod that doesn't work and can't get help for.

Edited, Oct 25th 2008 4:15am by Raygar
#37 Oct 25 2008 at 9:08 PM Rating: Decent
*
104 posts
I am also having the issue where WarReader is not functioning on a Windows XP pro machine.

SavedVariables.lua does not appear to be getting created while I am in game so there is nothing to upload (assuming that the file is made in the app directory that is). Either way I still show a "SavedVariables.lua - - no" on the interface.

Thanks!
#38 Oct 26 2008 at 12:02 PM Rating: Decent
Scholar
23 posts
Its inside the WarReader folder in the \user\interface I do however have a question, that maybe they can answer. I have it set to save per character. Not one big chunk, each character has their own folder inside \user\interface. Its a true/false command I turned on. That way if for some reason (WoW Habit) a characters file gets corrupt I can just copy and paste the new characters files over it and repair them.

So is it that I am on XP Pro and your mod/program doesn't work, or could it be that each character has their own folder it isn't working ??? Either way it isn't working, and I am tired of building up a file in each characters folder for nothing, and WILL delete the mod if I cant get any help. Last time I post or send emails, I am done, either I get help or it gets uninstalled. Game has to read your file, which at its smallest in any given characters folder its around 7 meg (14 meg at its largest) of wasted memory for running something that doesn't work. So either help me or I uninstall it. I mean you wouldn't have a broken program on your computer for nothing, which is what WarReader is to me right now.
#39 Oct 26 2008 at 4:55 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
The 502 Gateway error is a known issue. I need to rewrite how the data is received and parsed. The first part was done last week and was a backend change. It is functioning correctly and I'll get the rest done early next week.

Thanks for running WarReader.
#40 Oct 26 2008 at 4:55 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
Rishaka wrote:
I am also having the issue where WarReader is not functioning on a Windows XP pro machine.

SavedVariables.lua does not appear to be getting created while I am in game so there is nothing to upload (assuming that the file is made in the app directory that is). Either way I still show a "SavedVariables.lua - - no" on the interface.

Thanks!


Is it being saved in user/interface/AllCharacters/WarReader/ as SavedVariables.lua?
#41 Oct 27 2008 at 8:05 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
Raygar wrote:
Its inside the WarReader folder in the \user\interface I do however have a question, that maybe they can answer. I have it set to save per character. Not one big chunk, each character has their own folder inside \user\interface. Its a true/false command I turned on. That way if for some reason (WoW Habit) a characters file gets corrupt I can just copy and paste the new characters files over it and repair them.

So is it that I am on XP Pro and your mod/program doesn't work, or could it be that each character has their own folder it isn't working ??? Either way it isn't working, and I am tired of building up a file in each characters folder for nothing, and WILL delete the mod if I cant get any help. Last time I post or send emails, I am done, either I get help or it gets uninstalled. Game has to read your file, which at its smallest in any given characters folder its around 7 meg (14 meg at its largest) of wasted memory for running something that doesn't work. So either help me or I uninstall it. I mean you wouldn't have a broken program on your computer for nothing, which is what WarReader is to me right now.


This answers why your files aren't uploading. We weren't even aware that you could do this until you posted about it. We'll have a new version of WarReader available which will handled multiple directories in the next day or two. I'm rewriting the backend we use at the same time so it can handle some enhancements we've made.
#42 Oct 29 2008 at 4:45 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
We've updated the WarReader program to watch multiple character directories, now. Thanks everyone for all your input.

Due to the changes I've made, your uploads might not appear on the site for up to 10 minutes.

Please let me know about any issues.
#43 Oct 31 2008 at 3:26 AM Rating: Decent
Hi Nizdaar,

I'm playing on frFR Gisoreux with an enGB client, I know you are not managing other langs than enGB for now but I have read you're still collecting frFR datas so I used it 2 days ago without problems, was gathering and uploading the datas fine but since yesterday this is impossible to upload, the client reports "error" with no other message, clicking "Retry" gives "error" in the next 5 seconds. tried to completely uninstall it, also completely deleted the SavedVariables.lua file to write a fresh one didn't fixed the prob, its gathering just fine but always faialing at uploading. I know well my home network, no firewall or AV blocking it.

Throw me a PM if you want my IP or check the IP from that post if you want to deeply debug the issues in logs. I'm using the WarReader logged in as Merah else.

Edited, Oct 31st 2008 7:33am by Merah
#44 Oct 31 2008 at 3:29 AM Rating: Good
Scholar
23 posts
Ok I am sort of still in the same spot. It is reading all the folders, so it sees every .lua it needs to upload. But when I fire it u0p it says check login and password. I do and have done it a jillion times. So I turn it to anonymous and it still says invalid password or login, even when I set it to anonymous.

Any ideas ?? I cant log in, even had my password reset, which by the way when I try to set it back to what I want, I get an error page. I cant log in, nor can I send it anonymous, so any input would be helpful. Sorry for taking so long to respond, been sick last few days.
#45 Oct 31 2008 at 3:46 AM Rating: Decent
Scholar
23 posts
A little comedy on the change password page. Not only does it give an error, but it gives an error for the give an error page, none of it loads. So i get an Error on the "You have an Error page", telling me the error page is having an error telling me I have an error. Lol now go figure that all up :P

Quote:
Not Found

The requested URL /db/user.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c Server at war.allakhazam.com Port 80


So if possible, please fix the change password, and I will try it again once I set my new password, because the one you sent me allows me to log into the site, but not into WarReader.
#46 Oct 31 2008 at 4:12 AM Rating: Decent
strange I do not phisically see a password problem since I can login fine but it seems my unknown "error" bug could be linked to your issue, I think we're in the same bug boat =)
Good job anyway working on the war.Allakhazam, WarDB is so bugged I'd like to have an alternative, you've more experience on DB than them, I'm sure you could put WarDB the alternative.

Else I have a few suggestions about the project enhancement.

-Don't list items that have no drop, vendor, etc informations, this is much than annoying when you find the item you want but no infos where to get it :(
-Any NPC should have loc infos, this is much than a crusade to find them when you're playing on non-english servers
-In which version the item has been discovered, WarDB is listing items that were in closed or open beta and are no more available now.
-Who discovered
-Give us a private panel to check at what do we have contributed, JudgeHype.com a french WoW db does this just with numbers, you see the sum of all items you updated/added for example.
#47 Nov 02 2008 at 8:25 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
Merah wrote:

-Don't list items that have no drop, vendor, etc informations, this is much than annoying when you find the item you want but no infos where to get it :(


It's not possible to get the info on how to obtain everything with the API which Warhammer provides. Quest items and RvR only drops especially.

Merah wrote:

-Any NPC should have loc infos, this is much than a crusade to find them when you're playing on non-english servers


We should have locs for any mobs in our database. Any examples?

Merah wrote:

-In which version the item has been discovered, WarDB is listing items that were in closed or open beta and are no more available now.


Good idea. I've added tracking that to quests and items. We have other means to detect items that were in beta that aren't in game anymore. I don't think we have more than a handful if any, though.

Merah wrote:

-Who discovered


Been on my list to add for a while. Done.

Merah wrote:

-Give us a private panel to check at what do we have contributed, JudgeHype.com a french WoW db does this just with numbers, you see the sum of all items you updated/added for example.


Planned as well, hopefully in the next day or two I'll get a chance to do this.
#48 Nov 02 2008 at 8:40 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
Raygar wrote:
A little comedy on the change password page. Not only does it give an error, but it gives an error for the give an error page, none of it loads. So i get an Error on the "You have an Error page", telling me the error page is having an error telling me I have an error. Lol now go figure that all up :P

Quote:
Not Found

The requested URL /db/user.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c Server at war.allakhazam.com Port 80


So if possible, please fix the change password, and I will try it again once I set my new password, because the one you sent me allows me to log into the site, but not into WarReader.


I've fixed the password error.

I reviewed the logs and it appears that there is a password mismatch.
#49 Nov 02 2008 at 8:57 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
Raygar wrote:
Ok I am sort of still in the same spot. It is reading all the folders, so it sees every .lua it needs to upload. But when I fire it u0p it says check login and password. I do and have done it a jillion times. So I turn it to anonymous and it still says invalid password or login, even when I set it to anonymous.

Any ideas ?? I cant log in, even had my password reset, which by the way when I try to set it back to what I want, I get an error page. I cant log in, nor can I send it anonymous, so any input would be helpful. Sorry for taking so long to respond, been sick last few days.


You can delete the SavedVariable.lua files if you'd like. I checked and your anonymous uploads worked.

Let me know if there's any further problems.
#50 Nov 28 2008 at 10:35 AM Rating: Decent
2 posts
How long does it take for the database to be updated with what I uploaded?I'm not seeing the I tems I uploaded.I uploaded Sanctified Hoeth Robe which is a Purple Item but when I do a search it brings up a green I tem uploaded by someone else.
#51 Dec 01 2008 at 2:36 PM Rating: Excellent
Bad j00 j00
ZAM Administrator
Avatar
***
2,157 posts
We had an issue with the server that processes the logs over the weekend. Normally no more than a few minutes.

Your item should be appearing now.
« Previous 1 2
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 14 All times are in CDT
Anonymous Guests (14)